const regex = /\[(quote)=[^]]+\](?>(?R)|.)*?\[\/quote]/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(quote)=[^]]+\\](?>(?R)|.)*?\\[\\\/quote]', 'gsi')
const str = `one,two,3,(4,five),six,(seven),,(8,9,ten),eleven,(twelve,13,14,fifteen)
[quote=test][quote=test]for sure[/quote]
Test
[/quote]
[this should not be removed]
Dont remove me
[quote=test]
s
[quote=test]for s
[quote=test]for sure[/quote]
sure[/quote]
Test2
[/quote]
x
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}