re = /\[(quote)=[^]]+\](?>(?R)|.)*?\[\/quote]/i
str = 'one,two,3,(4,five),six,(seven),,(8,9,ten),eleven,(twelve,13,14,fifteen)
[quote=test][quote=test]for sure[/quote]
Test
[/quote]
[this should not be removed]
Dont remove me
[quote=test]
s
[quote=test]for s
[quote=test]for sure[/quote]
sure[/quote]
Test2
[/quote]
x
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end