const regex = /[^a-z0-9\-._]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-z0-9\\-._]', 'gi')
const str = `_;<!--Invalid--!"s"' null`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);