$re = '/[^a-z0-9\-._]/i';
$str = '_;<!--Invalid--!"s"\' null';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;