import re
regex = re.compile(r"[^a-z0-9\-._]", flags=re.IGNORECASE)
test_str = "_;<!--Invalid--!\"s\"' null"
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)