use strict;
my $str = '_;<!--Invalid--!"s"\' null';
my $regex = qr/[^a-z0-9\-._]/ip;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";