using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(className="")([^""]*)("")|(className={`)([^`]*)(`})";
string input = @"<div className={`p-2 big ? ""mt-2"" : ""mt-0""`}>hello</div>
<div className=""bg-gray-500"">world</div>
<div className={`p-2 big ? ""mt-2"" : ""mt-0""`}>hello</div>
<div className=""bg-gray-500"">world</div>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}