import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(className=\")([^\"]*)(\")|(className=\\{`)([^`]*)(`\\})";
final String string = "<div className={`p-2 big ? \"mt-2\" : \"mt-0\"`}>hello</div>\n"
+ "<div className=\"bg-gray-500\">world</div>\n"
+ "<div className={`p-2 big ? \"mt-2\" : \"mt-0\"`}>hello</div>\n"
+ "<div className=\"bg-gray-500\">world</div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}