import re
regex = re.compile(r"(className=\")([^\"]*)(\")|(className={`)([^`]*)(`})")
test_str = ("<div className={`p-2 big ? \"mt-2\" : \"mt-0\"`}>hello</div>\n"
"<div className=\"bg-gray-500\">world</div>\n"
"<div className={`p-2 big ? \"mt-2\" : \"mt-0\"`}>hello</div>\n"
"<div className=\"bg-gray-500\">world</div>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")