$re = '/(className=")([^"]*)(")|(className={`)([^`]*)(`})/';
$str = '<div className={`p-2 big ? "mt-2" : "mt-0"`}>hello</div>
<div className="bg-gray-500">world</div>
<div className={`p-2 big ? "mt-2" : "mt-0"`}>hello</div>
<div className="bg-gray-500">world</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);