// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(className=")([^"]*)(")|(className={`)([^`]*)(`})"#).unwrap();
let string = "<div className={`p-2 big ? \"mt-2\" : \"mt-0\"`}>hello</div>
<div className=\"bg-gray-500\">world</div>
<div className={`p-2 big ? \"mt-2\" : \"mt-0\"`}>hello</div>
<div className=\"bg-gray-500\">world</div>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}