import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^a]|a+[^ab]|a+b[ab]*[^abc])*[ab]*$";
final String string = "a\n"
+ "ab\n"
+ "abc\n"
+ "abcd\n"
+ "abcab\n"
+ "b\n"
+ "ac\n"
+ "bc\n"
+ "ha\n"
+ "hab\n"
+ "habc\n"
+ "habcd\n"
+ "habcab\n"
+ "haab\n"
+ "haabc\n"
+ "haabcd\n"
+ "haba\n"
+ "habab\n"
+ "hababc\n"
+ "hababcd\n"
+ "ababd\n"
+ "abbd\n"
+ "aabbd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}