#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![\s._])[^~#%&*{}+:<>?|\n]{1,50}(?<![.]) - [^<>\n]*(?:<(?![a-z0-9]{8}\.domain\.com@emea\.teams\.ms>).{1,256})?"
Local $sString = "MonkeyChannel - MonkeyTeam" & @CRLF & _
"MonkeyChannel - MonkeyTeam <12337aab.domain.com@emea.teams.ms>" & @CRLF & _
"MonkeyChannel - MonkeyTeam <22337aac.domain.net@emea.teams.ms>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")