import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![\\s._])[^~#%&*\\{\\}+:<>?|\\n]{1,50}(?<![.]) - [^<>\\n]*(?:<(?![a-z0-9]{8}\\.domain\\.com@emea\\.teams\\.ms>).{1,256})?";
final String string = "MonkeyChannel - MonkeyTeam\n"
+ "MonkeyChannel - MonkeyTeam <12337aab.domain.com@emea.teams.ms>\n"
+ "MonkeyChannel - MonkeyTeam <22337aac.domain.net@emea.teams.ms>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}