use strict;
my $str = 'MonkeyChannel - MonkeyTeam
MonkeyChannel - MonkeyTeam <12337aab.domain.com@emea.teams.ms>
MonkeyChannel - MonkeyTeam <22337aac.domain.net@emea.teams.ms>';
my $regex = qr/^(?![\s._])[^~#%&*{}+:<>?|\n]{1,50}(?<![.]) - [^<>\n]*(?:<(?![a-z0-9]{8}\.domain\.com@emea\.teams\.ms>).{1,256})?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}