const regex = /^(?![\s._])[^~#%&*{}+:<>?|\n]{1,50}(?<![.]) - [^<>\n]*(?:<(?![a-z0-9]{8}\.domain\.com@emea\.teams\.ms>).{1,256})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![\\s._])[^~#%&*{}+:<>?|\\n]{1,50}(?<![.]) - [^<>\\n]*(?:<(?![a-z0-9]{8}\\.domain\\.com@emea\\.teams\\.ms>).{1,256})?', 'gm')
const str = `MonkeyChannel - MonkeyTeam
MonkeyChannel - MonkeyTeam <12337aab.domain.com@emea.teams.ms>
MonkeyChannel - MonkeyTeam <22337aac.domain.net@emea.teams.ms>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}