$re = '/^(?![\s._])[^~#%&*{}+:<>?|\n]{1,50}(?<![.]) - [^<>\n]*(?:<(?![a-z0-9]{8}\.domain\.com@emea\.teams\.ms>).{1,256})?/m';
$str = 'MonkeyChannel - MonkeyTeam
MonkeyChannel - MonkeyTeam <12337aab.domain.com@emea.teams.ms>
MonkeyChannel - MonkeyTeam <22337aac.domain.net@emea.teams.ms>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);