using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\D)\.(\D)";
string substitution = @"\1 \2";
string input = @"FRAME WINDOW MASTER. 160.055-44.9 ADULT Z68.41
Hello.World";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}