// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\D)\.(\D)").unwrap();
let string = "FRAME WINDOW MASTER. 160.055-44.9 ADULT Z68.41
Hello.World";
let substitution = "\\1 \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}