package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(mini|super|hiper)?mercado$`)
var str = `____________Sim_
mercado
minimercado
supermercado
hipermercado
____________Não_
mercador
mini
valtermercado`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}