re = /^(mini|super|hiper)?mercado$/m
str = '____________Sim_
mercado
minimercado
supermercado
hipermercado
____________Não_
mercador
mini
valtermercado'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end