$re = '/^(mini|super|hiper)?mercado$/m';
$str = '____________Sim_
mercado
minimercado
supermercado
hipermercado
____________Não_
mercador
mini
valtermercado';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);