const regex = new RegExp('^(mini|super|hiper)?mercado$', 'gm')
const str = `____________Sim_
mercado
minimercado
supermercado
hipermercado
____________Não_
mercador
mini
valtermercado`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}