#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(http.*:)\(.*\)(.*)"
Local $sString = "https://(Username):(Password)@bitbucket.org/...../repo.git"
Local $sSubst = "\1*****\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)