import re
regex = re.compile(r"(http.*:)\(.*\)(.*)")
test_str = "https://(Username):(Password)@bitbucket.org/...../repo.git"
subst = "\\1*****\\2"
result = regex.sub(subst, test_str)
if result:
print(result)