use strict;
my $str = 'https://(Username):(Password)@bitbucket.org/...../repo.git';
my $regex = qr/(http.*:)\(.*\)(.*)/p;
my $subst = '\\1*****\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";