$re = '/(http.*:)\(.*\)(.*)/';
$str = 'https://(Username):(Password)@bitbucket.org/...../repo.git';
$subst = "\1*****\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;