const regex = new RegExp('(http.*:)\\(.*\\)(.*)', 'g')
const str = `https://(Username):(Password)@bitbucket.org/...../repo.git`;
const subst = `\1*****\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);