# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!<span[^<>]*class=)(?=<span(.*)>([^<>]*\.))(?!<span.*>xyz\.<\/span>).*$/<span class="other"\1>\2<\/span>/gm;t' <<< "<span>abc.</span>
<span>bcd</span>
<span>xyz.</span>
<span class=\"good\">abc</span>
<span class=\"good\">abc.</span>xyz.
<span class=\"good\">xyz.</span>
<span id=\"whatever\">def.</span>
<span id=\"whatever\">xyz.</span>
<span class=\"good\" id=\"whatever\">ghi.</span>
<span class=\"bad\" id=\"whatever\">jkl.</span>
<span id=\"whatever\" class=\"good\">abc.</span>
"