import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!<span[^<>]*class=)(?=<span(.*)>([^<>]*\\.))(?!<span.*>xyz\\.</span>).*$";
final String string = "<span>abc.</span>\n"
+ "<span>bcd</span>\n"
+ "<span>xyz.</span>\n"
+ "<span class=\"good\">abc</span>\n"
+ "<span class=\"good\">abc.</span>xyz.\n"
+ "<span class=\"good\">xyz.</span>\n"
+ "<span id=\"whatever\">def.</span>\n"
+ "<span id=\"whatever\">xyz.</span>\n"
+ "<span class=\"good\" id=\"whatever\">ghi.</span>\n"
+ "<span class=\"bad\" id=\"whatever\">jkl.</span>\n"
+ "<span id=\"whatever\" class=\"good\">abc.</span>\n";
final String subst = "<span class=\"other\"\\1>\\2</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}