const regex = new RegExp('^(?!<span[^<>]*class=)(?=<span(.*)>([^<>]*\\.))(?!<span.*>xyz\\.</span>).*$', 'gm')
const str = `<span>abc.</span>
<span>bcd</span>
<span>xyz.</span>
<span class="good">abc</span>
<span class="good">abc.</span>xyz.
<span class="good">xyz.</span>
<span id="whatever">def.</span>
<span id="whatever">xyz.</span>
<span class="good" id="whatever">ghi.</span>
<span class="bad" id="whatever">jkl.</span>
<span id="whatever" class="good">abc.</span>
`;
const subst = `<span class="other"\1>\2</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);