use strict;
my $str = '<span>abc.</span>
<span>bcd</span>
<span>xyz.</span>
<span class="good">abc</span>
<span class="good">abc.</span>xyz.
<span class="good">xyz.</span>
<span id="whatever">def.</span>
<span id="whatever">xyz.</span>
<span class="good" id="whatever">ghi.</span>
<span class="bad" id="whatever">jkl.</span>
<span id="whatever" class="good">abc.</span>
';
my $regex = qr/^(?!<span[^<>]*class=)(?=<span(.*)>([^<>]*\.))(?!<span.*>xyz\.</span>).*$/mp;
my $subst = '<span class="other"\\1>\\2</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";