# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!<span[^<>]*class=)(?=<span(.*)>([^<>]*\.))(?!<span.*>xyz\.</span>).*$"
test_str = ("<span>abc.</span>\n"
"<span>bcd</span>\n"
"<span>xyz.</span>\n"
"<span class=\"good\">abc</span>\n"
"<span class=\"good\">abc.</span>xyz.\n"
"<span class=\"good\">xyz.</span>\n"
"<span id=\"whatever\">def.</span>\n"
"<span id=\"whatever\">xyz.</span>\n"
"<span class=\"good\" id=\"whatever\">ghi.</span>\n"
"<span class=\"bad\" id=\"whatever\">jkl.</span>\n"
"<span id=\"whatever\" class=\"good\">abc.</span>\n")
subst = "<span class=\"other\"\\1>\\2</span>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.