#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(["].*?["])|([[:alnum:]_\$]+)"
Local $sString = "HELLO VERSION MIN=$min MAX=$max USER="xxx" PASSWORD="yyy"" & @CRLF & _
"" & @CRLF & _
"FIRST SECOND ARG1=$value ARG2="with space""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")