// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(["].*?["])|([[:alnum:]_\$]+)"#).unwrap();
let string = "HELLO VERSION MIN=$min MAX=$max USER=\"xxx\" PASSWORD=\"yyy\"
FIRST SECOND ARG1=$value ARG2=\"with space\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}