$re = '/(["].*?["])|([[:alnum:]_\$]+)/m';
$str = 'HELLO VERSION MIN=$min MAX=$max USER="xxx" PASSWORD="yyy"
FIRST SECOND ARG1=$value ARG2="with space"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);