using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([""].*?[""])|([[:alnum:]_\$]+)";
string input = @"HELLO VERSION MIN=$min MAX=$max USER=""xxx"" PASSWORD=""yyy""
FIRST SECOND ARG1=$value ARG2=""with space""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}