const regex = /(?i)(\btree\b)(?>(?!(?1)).)*?\bhouse\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(\\btree\\b)(?>(?!(?1)).)*?\\bhouse\\b', 'g')
const str = `the tree is green. a tree house. a new house would be great. here is a tree with a house.
a Tree house in a tree.
here is a tree
with a house
a tree in a house?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}