$re = '/(?i)(\btree\b)(?>(?!(?1)).)*?\bhouse\b/';
$str = 'the tree is green. a tree house. a new house would be great. here is a tree with a house.
a Tree house in a tree.
here is a tree
with a house
a tree in a house?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);