import Foundation
let pattern = #"(?i)(\btree\b)(?>(?!(?1)).)*?\bhouse\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
the tree is green. a tree house. a new house would be great. here is a tree with a house.
a Tree house in a tree.
here is a tree
with a house
a tree in a house?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)