re = /(?i)(\btree\b)(?>(?!(?1)).)*?\bhouse\b/
str = 'the tree is green. a tree house. a new house would be great. here is a tree with a house.
a Tree house in a tree.
here is a tree
with a house
a tree in a house?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end