#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx) ^From:\s.(?P<from>.+)\R" & @CRLF & _
" Sent:\s(?P<sent>.+)\R" & @CRLF & _
" To:\s(?P<to>.+)\R" & @CRLF & _
" Subject:\s(?P<subject>.+)"
Local $sString = "here is something as well" & @CRLF & _
"" & @CRLF & _
"From: ***********************" & @CRLF & _
"Sent: ***********************" & @CRLF & _
"To: ***********************" & @CRLF & _
"Subject: *******************" & @CRLF & _
"" & @CRLF & _
"some text here which should not be matched"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")