using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ^From:\s.(?P<from>.+)\R
Sent:\s(?P<sent>.+)\R
To:\s(?P<to>.+)\R
Subject:\s(?P<subject>.+)";
string input = @"here is something as well
From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************
some text here which should not be matched";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}