$re = '~ ^From:\s.(?P<from>.+)\R
Sent:\s(?P<sent>.+)\R
To:\s(?P<to>.+)\R
Subject:\s(?P<subject>.+)~mx';
$str = 'here is something as well
From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************
some text here which should not be matched';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);