import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ^From:\\s.(?P<from>.+)\\R\n"
+ " Sent:\\s(?P<sent>.+)\\R\n"
+ " To:\\s(?P<to>.+)\\R\n"
+ " Subject:\\s(?P<subject>.+)";
final String string = "here is something as well\n\n"
+ "From: ***********************\n"
+ "Sent: ***********************\n"
+ "To: ***********************\n"
+ "Subject: *******************\n\n"
+ "some text here which should not be matched";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}