import Foundation
let pattern = #"""
^From:\s.(?P<from>.+)\R
Sent:\s(?P<sent>.+)\R
To:\s(?P<to>.+)\R
Subject:\s(?P<subject>.+)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
here is something as well
From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************
some text here which should not be matched
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}