import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\(\\[)\\d{7}(?=\\]\\))";
final String string = "[15211Z: 2012-09-12] ([5202900]) this matches\n"
+ "[15211Z: 2012-09-12] [5202900] this doesn't match !";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}