const regex = /(?<=\(\[)\d{7}(?=\]\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\(\\[)\\d{7}(?=\\]\\))', 'g')
const str = `[15211Z: 2012-09-12] ([5202900]) this matches
[15211Z: 2012-09-12] [5202900] this doesn't match !`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}