re = /(?<=\(\[)\d{7}(?=\]\))/
str = '[15211Z: 2012-09-12] ([5202900]) this matches
[15211Z: 2012-09-12] [5202900] this doesn\'t match !'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end