#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256})(\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*"
Local $sString = "http://wheaton.com/skin/media/main.js" & @CRLF & _
"https://wheaton.com/skin/media/main.js" & @CRLF & _
"http://www.wheaton.com/skin/media/main.js" & @CRLF & _
"https://www.wheaton.com/skin/media/main.js" & @CRLF & _
"" & @CRLF & _
"http://wheaton.com/media/media/main.css" & @CRLF & _
"https://wheaton.com/media/media/main.css" & @CRLF & _
"http://www.wheaton.com/media/media/main.css" & @CRLF & _
"https://www.wheaton.com/media/media/main.css" & @CRLF & _
"" & @CRLF & _
"http://wheaton.com/skin/media/main.png" & @CRLF & _
"https://wheaton.com/skin/media/main.jpg" & @CRLF & _
"http://www.wheaton.com/skin/media/main.jpeg" & @CRLF & _
"https://www.wheaton.com/skin/media/main.gif" & @CRLF & _
"" & @CRLF & _
"http://go.wheaton.com/skin/media/main.png" & @CRLF & _
"https://go.wheaton.com/skin/media/main.jpg" & @CRLF & _
"http://go.wheaton.com/skin/media/main.jpeg" & @CRLF & _
"https://go.wheaton.com/skin/media/main.gif" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")